AnyConnect GUI Text and Messages

IPsec, L2TP, Split tunneling, PPTP and all other VPN related posts.
Guest

AnyConnect GUI Text and Messages

Post by Guest » Sun Jun 27, 2010 9:56 pm

Has anyone had any success modifying the displayed text with the AnyConnect client? I currently have AnyConnect 2.5 deployed on our ASAs and have been unsuccessful in modifying some text field values next to the textboxes for entering your login credentials. Ive tried following the content in the following article:http://www.cisco.com/en/US/docs/securit ... #wp1075250 These are the changes made so far: #: e772fc3a60fb73c7d5c07b1e791d18f2msgid "Second Username:"msgstr "Username:" #: e772fc3a60fb73c7d5c07b1e791d18f2msgid "Second Password:"msgstr "Password:" See the attached image for what Im looking to change.

Guest

Re:AnyConnect GUI Text and Messages

Post by Guest » Sun Jun 27, 2010 11:24 pm

You should export the template to your pc and then make the modification.Then import it back and select the correct language which you are using. (I am using en-us). If it is still not working. Uninstall anyconnect client and try it again.

Guest

Re:AnyConnect GUI Text and Messages

Post by Guest » Sun Jun 27, 2010 11:57 pm

Thanks for the alternative approach, as I was attemping to make the changes inline on the ASDM by using the add and edit buttons on the ASDM. This time around, I reverted (deleted) my language templates, exported the default template, made the changes on the exported template, then imported en, en-ca, en-gb, and en-us using the modified exported template text file on my local PC. Afterwhich, I uninstalled the client on my client PC, then revisited the login portal page, logged in, and downloaded the client. Success. Its great that it worked, but Im not sure why my previous attempts failed.  The changes made inline were no different than the changes on the imported file.  The only difference was I edited the language templates in the ASDM rather than importing from a remote file, and I only tried en, and en-us. Either the inline editor is broken, or my ASA thinks its in Canada or the United Kingdom. 

Post Reply