RS-232 commands for a Sony TV connected to a DMP

Cisco CallManager, Cisco CallManager Express and IP Video
Guest

Re:RS-232 commands for a Sony TV connected to a DMP

Post by Guest » Wed Jul 14, 2010 2:28 pm

Hi Jeff, Can you tell me what you did to get your commands to work as you had the same problem as me until your last post? Also, is it possible to send me a copy of the output after you execute your command (either to turn the TV on or off)?  You can get the output by entering the following into a browser? http://<dmp ip address>:7777/get_param?p=*.*  where <dmp ip address> is the IP address of your DMP that you are using to control the TV. I would like to see if your DMP is configured differently to mine. Many thanksLinda

Guest

Re:RS-232 commands for a Sony TV connected to a DMP

Post by Guest » Wed Jul 14, 2010 4:02 pm

Linda, 1.) I created an Advanced Task to turn RS232 On and Off as follows: "RS232 ON"request type = "set"request=  init.startService_rs232=yes&rs232.device=/dev/ttyS1&mib.save=1&mng.reboot=1 "RS232 OFF"request type = "set" request =  init.startService_rs232=no&rs232.device=/dev/ttyS1&mib.save=1&mng.reboot=1 2.) Then I connected my DMP to the Sony FWD-40LX2F monitor using a "null modem" cable. 3.) I sent the "RS232 ON" command to the DMP. 4.) Then I ran the https://<dmp ip address>/get_param?p=rs232.*  in by browser to confirm the port was on. Your results should be: rs232.device     T_STRING     /dev/ttyS1rs232.speed     T_STRING     9600rs232.parity     T_STRING     noners232.data_size     T_STRING     8rs232.stop_bits     T_STRING     1rs232.flow_ctrl     T_STRING     noners232.tx_hex     T_STRING     rs232.tx_str     T_STRING     rs232.rx_buf     T_STRING     rs232.rx_overflow_flag     T_STRING     falsers232.tx_cnt     T_STRING     0rs232.rx_cnt     T_STRING     0 5.) I was then able to send the following command to the monitor via the DMP.Sony (Turn ON)Setrs232.tx_hex=8c000002018f Sony (Turn  OFF)Setrs232.tx_hex=8c000002008e  6.) I ran the following in my browser to get the results that I have attached to this response as DMP.txt http://<dmp  ip address>:7777/get_param?p=*.*   I hope this works for you.Jeff    

Guest

Re:RS-232 commands for a Sony TV connected to a DMP

Post by Guest » Wed Jul 14, 2010 5:17 pm

Thank you Jeff. Details you sent were great help. I found a difference between your output and mine which I think may be causing the issue. The RS-232: Control supported, non-DMTech displays command sent to my DMP before any commands to turn the TV on/off were sent: init.startService_dmttv=no&init.startService_rs232=yes&rs232.device=/dev/ttyS1&mib.save=1&mng.reboot=1 My output showed: init.startService_rs232 T_STRING yes..rs232.device T_STRING /dev/ttyS0rs232.speed T_STRING 9600rs232.parity T_STRING noners232.data_size T_STRING 8rs232.stop_bits T_STRING 1rs232.flow_ctrl T_STRING noners232.tx_hex T_STRING 8C000002008Ers232.tx_str T_STRING rs232.rx_buf T_STRING rs232.rx_overflow_flag T_STRING falsers232.tx_cnt T_STRING 6rs232.rx_cnt T_STRING 0 Your output showed:init.startService_rs232 T_STRING yes..rs232.device T_STRING /dev/ttyS1rs232.speed T_STRING 9600rs232.parity T_STRING noners232.data_size T_STRING 8rs232.stop_bits T_STRING 1rs232.flow_ctrl T_STRING noners232.tx_hex T_STRING 8c000002018frs232.tx_str T_STRING rs232.rx_buf T_STRING e9rs232.rx_overflow_flag T_STRING falsers232.tx_cnt T_STRING 60rs232.rx_cnt T_STRING 15 The line: rs232.device T_STRING /dev/ttyS0  is different from yours: rs232.device T_STRING /dev/ttyS1 I don understand why the "RS-232: Control supported, non-DMTech displays" clearly states: &rs232.device=/dev/ttyS1 but the output post sending the command shows: &rs232.device=/dev/ttyS0 My understanding is that /dev/ttyS0 is a different comm port than /dev/ttyS1 and that could be causing the issue.  Do you know how to check the permissions on the DMP for /dev/ttyS0 and /dev/ttyS1?  Im thinking if the permissions are not set correctly then the commands will not flow to the correct port....in this instance /dev/ttyS1. ThanksLinda

Guest

Re:RS-232 commands for a Sony TV connected to a DMP

Post by Guest » Wed Jul 14, 2010 6:27 pm

Linda,I am not sure how to check the permissions on the DMP for /dev/ttyS0 and /dev/ttyS1. However, you may want to try this: 1.) Go into your DMP settings and "Restore Default Settings." 2.) Instead of using the "RS-232: Control supported, non-DMTech displays" action from the Advanced Tasks try creating our own RS-232 on/off commands using: "RS232 ON"request type = "set"request=   init.startService_rs232=yes&rs232.device=/dev/ttyS1&mib.save=1&mng.reboot=1 "RS232 OFF"request type = "set" request =   init.startService_rs232=no&rs232.device=/dev/ttyS1&mib.save=1&mng.reboot=1 3.) Then try your Sony commands: Sony (Turn ON)Setrs232.tx_hex=8c000002018f Sony (Turn  OFF)Setrs232.tx_hex=8c000002008e 4.) If this doesn work, I would try another DMP. I will let you know if I find anything else.Jeff

Guest

Re:RS-232 commands for a Sony TV connected to a DMP

Post by Guest » Wed Jul 14, 2010 6:32 pm

Hi Jeff, I believe my issue is in the way the DMPs have been configured.  I was able to finally get to a DMP attached to a Panasonic TV where the RS-232 commands worked so I unplugged the DMP and then plugged it into Sony TV and was able to successfully send the RS-232 commands to both turn the TV on and off. I now need to compare the configuration of the two DMPs to see whats different (the DMPs were not configured by me but rather by two separate companies). Other than pointing a browser to the DMP IP address to see the settings, do you know where the file containing the configuration (particularly the baud rate details) is located and how can I access it? Many thanks for your help so far. CheersLinda

Post Reply