Voice messages not being delivered and being moved to the failed directory

Cisco CallManager, Cisco CallManager Express and IP Video
Guest

Voice messages not being delivered and being moved to the failed directory

Post by Guest » Fri Jul 30, 2010 9:03 pm

Running Cisco Unity 7 ES40 and Exchange 2010 SP1 on an AD 2008 R2 domain. Everything was working great for months then all of a sudden we noticed that voice messages were not being delivered to some voice mail accounts. The messages end up in the D:CommServerUnityMTAFailed on the Unity server but only if it was an external call. If it is an internal call the voice message just disappears. I have the following in the event viewer on Unity. Event Type: ErrorEvent Source: CiscoUnity_ConvMsgEvent Category: Network Event ID: 10012Date:  2/24/2011Time:  7:44:43 AMUser:  N/AComputer: GCSCIPTUDescription:This message has the following recipients : [voicemail recipient here] .   The recipient mailboxes may be disabled or inaccessible, Cisco Unity may be having trouble connecting with the partner server, or the Cisco Unity messaging component may not be properly configured. -----------------------------------------------------------------------------------------------  Event Type: ErrorEvent Source: CiscoUnity_UMREvent Category: UMR Thread Error Event ID: 113Date:  2/23/2011Time:  6:09:01 PMUser:  N/AComputer: GCSCIPTUDescription:A message with the subject:<Unknown> to recipient <Unknown> could not be delivered [Error:80040920]. It was moved to the failed directory.  This can occur for several reasons: the recipient mailbox may be disabled or inaccessible, Cisco Unity may be having trouble connecting with the partner server, or the Cisco Unity messaging component may not be properly configured.  If this condition persists, contact Cisco TAC. 0x00000848-----------------------------------------------------------------------------------------------  This is not affecting any actual users but just department voice mail accounts. That does not make much sense though, since they are AD accounts like everyone else. Any ideas???

Guest

Re:Voice messages not being delivered and being moved to the failed directory

Post by Guest » Fri Jul 30, 2010 9:13 pm

Hi Kevin, Just out of curiosity, did you apply any Microsoft hotfixes/patches to any of your servers in Active Directory (DC, GC, Exchange) before it started getting noticed?  Or on Unity for that matter?  Theres a tracking defect that exists for a issue with mail not being delivered to users who are hidden in AD here: http://tools.cisco.com/Support/BugToolK ... CSCti09152 I would double check to see if the users that are experiencing the problem are users that may be hidden in AD.  Also, check to see if any of your servers were recently patched with this KB: http://support.microsoft.com/kb/2264107 Brad

Guest

Re:Voice messages not being delivered and being moved to the failed directory

Post by Guest » Fri Jul 30, 2010 9:46 pm

That is exactily the issue. A few hours ago I just decided to unhide the addresses in AD and then it started working again. I applied a number of updates on the day the issue started, one of which is KB2264107 (on the exchange server). I also installed Rollup 2 for Exchange 2010 SP1. Thanks for giving me the bug link, I will keep an eye on this.

Post Reply