CUPS and System Dashboard Error

Cisco CallManager, Cisco CallManager Express and IP Video
Guest

Re:CUPS and System Dashboard Error

Post by Guest » Thu Dec 30, 2010 10:45 am

I believe it to still be an issue in 8.x. I have the same two messages about my CUPS gateway SRV and the one about the CCM trunk SRV unless I have something misconfigured.

 

- Invalid Presence Gateway. Unreachable gateways include:_sipcucm._tcp.domain.com

- Failed to verify host connectivity. Please check if using DNS SRV for host _sippres._tcp.domain.com

 

I had my Presence status updating, but it stopped. Trying to figure out why.


Guest

Re:CUPS and System Dashboard Error

Post by Guest » Thu Dec 30, 2010 11:54 am

William,

 

I am confused and interested more in your configuration of DNS SRV. I am not a DNS person.

 

I have two DNS SRV records created, one for CUCM and one for CUPS. I am most concerned with the one you configure on the CUCM SIP Trunk. My DNS SRV record is configured as so:

 

Record 1

Service: _sippres

Protocol: _tcp

Host that handles this service: pres01.domain.com

 

Record 2

Service: _sippres

Protocol: _tcp

Host that handles this service: pres02.domain.com

 

Now, putting _sippres._tcp.domain.com on my SIP Trunk in CUCM isn allowing a SIP connection to form and I don receive presence status. CUCM can resolve the DNS SRV either. Ive read that you do not need to put the "_sippres._tcp." portion, but that just leaves my domain name "domain.com".

 

I see in other examples, including yours that you added a hotsname after the "_tcp" so it appeared as "_sip._tcp.<hostname>.domain.com". I don see where you add that hostname in the DNS SRV record. Am I missing something?

 

The only other option that I can think of is create a new A record that points to both of my CUPS servers such as "pres.domain.com". Then remove my DNS SRV records and create one just like:

 

Service: _sippres or _sip

Protocol: _tcp

Host that handles this service: pres.domain.com

 

Then in CUCM, don add the "_sippres._tcp.pres.domain.com", but just put the "pres.domain.com" and check the "Destination is an SRV" checkbox. Is this the correct way of doing it? It seems like it would juts be acting more as an A record than a DNS SRV at this point.


Post Reply